Nikon 1 V3 trigger-capture fails

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Nikon 1 V3 trigger-capture fails

Alexander Smith
Hello gphoto2 devs,

You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.

I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!

Alexander Smith
Senior Embedded Systems Developer, PrecisionHawk
www.precisionhawk.com


------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel

V3_trigger-capture_failed.txt (63K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Nikon 1 V3 trigger-capture fails

Alexander Smith
Hello gphoto2 devs,

Sorry if this turns into a double-post. On my initial attempt to post this, I got a response from gphoto-devel that said the attachment was too large. This time, I have compresed it with xz.

You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.

I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!

Alexander Smith
Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com

Alexander Smith
Senior Embedded Systems Developer, PrecisionHawk
www.precisionhawk.com

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel

V3_trigger-capture_failed.txt.xz (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Nikon 1 V3 trigger-capture fails

Marcus Meissner
Hi,

could you try this patch, it seems to be the difference between capture image and trigger image.

Ciao, Marcus
On Tue, Nov 08, 2016 at 09:29:54PM +0000, Alexander Smith wrote:

> Hello gphoto2 devs,
>
> Sorry if this turns into a double-post. On my initial attempt to post this, I got a response from gphoto-devel that said the attachment was too large. This time, I have compresed it with xz.
>
> You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.
>
> I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!
>
> Alexander Smith
> Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com
>
> Alexander Smith
> Senior Embedded Systems Developer, PrecisionHawk
> www.precisionhawk.com

> ------------------------------------------------------------------------------
> Developer Access Program for Intel Xeon Phi Processors
> Access to Intel Xeon Phi processor-based developer platforms.
> With one year of Intel Parallel Studio XE.
> Training and support from Colfax.
> Order your platform today. http://sdm.link/xeonphi

> _______________________________________________
> Gphoto-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gphoto-devel


--
Marcus Meissner,SUSE LINUX GmbH; Maxfeldstrasse 5; D-90409 Nuernberg; Zi. 3.1-33,+49-911-740 53-432,,serv=loki,mail=wotan,type=real <[hidden email]>

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel

xx.pat (885 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Nikon 1 V3 trigger-capture fails

Alexander Smith
(I just realized my reply didn't go to the right place. Resending to the gphoto-devel list.)

That patch doesn't apply against the release 2.5.10. I applied it against the latest git commit (e5003ac for libgphoto2 and c069754 for gphoto2). Now, --trigger-capture doesn't produce an error, but there is still no image captured. Also, --capture-image now fails. I have attached both logs.

Alexander Smith

-----Original Message-----
From: Marcus Meissner [mailto:[hidden email]]
Sent: November 9, 2016 6:26 PM
To: Alexander Smith <[hidden email]>
Cc: [hidden email]
Subject: Re: [gphoto-devel] Nikon 1 V3 trigger-capture fails

Hi,

could you try this patch, it seems to be the difference between capture image and trigger image.

Ciao, Marcus
On Tue, Nov 08, 2016 at 09:29:54PM +0000, Alexander Smith wrote:

> Hello gphoto2 devs,
>
> Sorry if this turns into a double-post. On my initial attempt to post this, I got a response from gphoto-devel that said the attachment was too large. This time, I have compresed it with xz.
>
> You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.
>
> I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!
>
> Alexander Smith
> Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com
>
> Alexander Smith
> Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com

> ----------------------------------------------------------------------
> -------- Developer Access Program for Intel Xeon Phi Processors Access
> to Intel Xeon Phi processor-based developer platforms.
> With one year of Intel Parallel Studio XE.
> Training and support from Colfax.
> Order your platform today. http://sdm.link/xeonphi

> _______________________________________________
> Gphoto-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gphoto-devel


--
Marcus Meissner,SUSE LINUX GmbH; Maxfeldstrasse 5; D-90409 Nuernberg; Zi. 3.1-33,+49-911-740 53-432,,serv=loki,mail=wotan,type=real <[hidden email]>

------------------------------------------------------------------------------

_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel

20161110_V3_trigger-capture.log.xz (8K) Download Attachment
20161110_V3_capture-image.log.xz (10K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Nikon 1 V3 trigger-capture fails

Marcus Meissner-4
Hi,

Hmm, I added more checks that handle the a004 error as transient to GIT.

Can you check current git?

Ciao, Marcus


On Tue, Nov 15, 2016 at 04:23:10PM +0000, Alexander Smith wrote:

> (I just realized my reply didn't go to the right place. Resending to the gphoto-devel list.)
>
> That patch doesn't apply against the release 2.5.10. I applied it against the latest git commit (e5003ac for libgphoto2 and c069754 for gphoto2). Now, --trigger-capture doesn't produce an error, but there is still no image captured. Also, --capture-image now fails. I have attached both logs.
>
> Alexander Smith
>
> -----Original Message-----
> From: Marcus Meissner [mailto:[hidden email]]
> Sent: November 9, 2016 6:26 PM
> To: Alexander Smith <[hidden email]>
> Cc: [hidden email]
> Subject: Re: [gphoto-devel] Nikon 1 V3 trigger-capture fails
>
> Hi,
>
> could you try this patch, it seems to be the difference between capture image and trigger image.
>
> Ciao, Marcus
> On Tue, Nov 08, 2016 at 09:29:54PM +0000, Alexander Smith wrote:
> > Hello gphoto2 devs,
> >
> > Sorry if this turns into a double-post. On my initial attempt to post this, I got a response from gphoto-devel that said the attachment was too large. This time, I have compresed it with xz.
> >
> > You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.
> >
> > I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!
> >
> > Alexander Smith
> > Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com
> >
> > Alexander Smith
> > Senior Embedded Systems Developer, PrecisionHawk www.precisionhawk.com
>
>
> > ----------------------------------------------------------------------
> > -------- Developer Access Program for Intel Xeon Phi Processors Access
> > to Intel Xeon Phi processor-based developer platforms.
> > With one year of Intel Parallel Studio XE.
> > Training and support from Colfax.
> > Order your platform today. http://sdm.link/xeonphi
>
> > _______________________________________________
> > Gphoto-devel mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/gphoto-devel
>
>
> --
> Marcus Meissner,SUSE LINUX GmbH; Maxfeldstrasse 5; D-90409 Nuernberg; Zi. 3.1-33,+49-911-740 53-432,,serv=loki,mail=wotan,type=real <[hidden email]>



> ------------------------------------------------------------------------------

> _______________________________________________
> Gphoto-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gphoto-devel


------------------------------------------------------------------------------
_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel
Reply | Threaded
Open this post in threaded view
|

Re: Nikon 1 V3 trigger-capture fails

Alexander Smith
Hi Marcus,

I tested with git as of today. Capture-image and trigger-capture both still fail. Capture-image fails with error messages; trigger-capture fails silently. For your reference, these are the git hashes that where current at the time:
libgphoto2: 73852ad06a57cda28abcdbd91c7852bb59b7c2d8
   gphoto2: 6c1b36e6505f0d92a75a608937d9206f20ccef22
Log files are attached.

Alexander Smith
Senior Embedded Systems Developer, PrecisionHawk

-----Original Message-----
From: Marcus Meissner [mailto:[hidden email]]
Sent: November 20, 2016 2:04 PM
To: Alexander Smith <[hidden email]>
Cc: [hidden email]
Subject: Re: [gphoto-devel] Nikon 1 V3 trigger-capture fails

Hi,

Hmm, I added more checks that handle the a004 error as transient to GIT.

Can you check current git?

Ciao, Marcus


On Tue, Nov 15, 2016 at 04:23:10PM +0000, Alexander Smith wrote:

> (I just realized my reply didn't go to the right place. Resending to
> the gphoto-devel list.)
>
> That patch doesn't apply against the release 2.5.10. I applied it against the latest git commit (e5003ac for libgphoto2 and c069754 for gphoto2). Now, --trigger-capture doesn't produce an error, but there is still no image captured. Also, --capture-image now fails. I have attached both logs.
>
> Alexander Smith
>
> -----Original Message-----
> From: Marcus Meissner [mailto:[hidden email]]
> Sent: November 9, 2016 6:26 PM
> To: Alexander Smith <[hidden email]>
> Cc: [hidden email]
> Subject: Re: [gphoto-devel] Nikon 1 V3 trigger-capture fails
>
> Hi,
>
> could you try this patch, it seems to be the difference between capture image and trigger image.
>
> Ciao, Marcus
> On Tue, Nov 08, 2016 at 09:29:54PM +0000, Alexander Smith wrote:
> > Hello gphoto2 devs,
> >
> > Sorry if this turns into a double-post. On my initial attempt to post this, I got a response from gphoto-devel that said the attachment was too large. This time, I have compresed it with xz.
> >
> > You've helped us in the past with a different model Nikon camera, and I'm hoping you can help us again. This time we have a Nikon 1 V3 camera. With camera firmware 1.00, it worked fine. However, once the camera firmware is upgraded to 1.11, "gphoto2 --capture-image" works but "gphoto2 --trigger-capture fails" with "Error (-1: 'Unspecified error')". I'm using gphoto2-2.5.10. I'm afraid I can no longer test with camera firmware 1.00 - I have no way of downgrading the camera now that I have upgraded it, and Nikon is now shipping new cameras with firmware 1.11 already installed.
> >
> > I have attached a gphoto2 debug log file showing the problem. I hope this is as easy for you to fix as it was last time!
> >
> > Alexander Smith
> > Senior Embedded Systems Developer, PrecisionHawk
> > www.precisionhawk.com
> >
> > Alexander Smith
> > Senior Embedded Systems Developer, PrecisionHawk
> > www.precisionhawk.com
>
>
> > --------------------------------------------------------------------
> > --
> > -------- Developer Access Program for Intel Xeon Phi Processors
> > Access to Intel Xeon Phi processor-based developer platforms.
> > With one year of Intel Parallel Studio XE.
> > Training and support from Colfax.
> > Order your platform today. http://sdm.link/xeonphi
>
> > _______________________________________________
> > Gphoto-devel mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/gphoto-devel
>
>
> --
> Marcus Meissner,SUSE LINUX GmbH; Maxfeldstrasse 5; D-90409 Nuernberg;
> Zi. 3.1-33,+49-911-740 53-432,,serv=loki,mail=wotan,type=real
> <[hidden email]>


> ----------------------------------------------------------------------
> --------

> _______________________________________________
> Gphoto-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gphoto-devel


------------------------------------------------------------------------------

_______________________________________________
Gphoto-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gphoto-devel

20161121_V3_git_capture-image.log.xz (17K) Download Attachment
20161121_V3_git_trigger-capture.log.xz (18K) Download Attachment